Problemas con EasyPopulate

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas con EasyPopulate

Mensaje por jordigsanz el Vie Abr 17, 2009 2:45 pm

Buenos días,

Tenía instalado en mi admin de Zencart, la versión 1.2.5.4 de EasyPopulate, con la que he estado trabajando sin problemas. Subí artículos (1500 aprox) y luego sus correspondientes atributos, como digo todo sin complicaciones.

Ayer, subí otros 1500 artículos. Hasta aquí todo sin problemas.

A continuación, quise crear un archivo de atributos de todos los artículos de la tienda para, posteriomente, con Excel, modificar los de los artículos nuevos y "resubirlos". Al hacerlo, mi explorador (probado con Firefox, IE y Ópera), de devuelve un error interno del servidor 500 y no crea el archivo.

Pensando en que pudiera ser la versión de EP instalada, acualicé a EasyPopulate, versión "1.2.5.5.csv", que he bajado desde la sección "add-ons" de Zencart.com, pero sigo teniendo el mismo problema.

Me he puesto a bucear por las FAQS de zencart.com. No he entendido al 100% el problema, pero creo haber captado la idea general. Por favor, a ver si algún alma caritativa me sabe ayudar:

Parece ser que el error está en los límites de memoria del servidor, algo configurable desde el archivo php.ini
He creado éste archivo (Pues no se encuentra en mi servidor) con la siguiente sintaxis:

";;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 90 ; Maximum execution time of each script, in seconds
max_input_time = 90 ; Maximum amount of time each script may spend parsing request data
memory_limit = 64M ; Maximum amount of memory a script may consume (10MB)"

Para así aumentar los límites de la memoria. Creo haber entendido que cuando no se encuentra en el servidor el archivo php.ini, es porque se está ejecutando un modo concreto de Apache (no recuerso el nombre, sorry) pero que se puede subir al directorio /pub para que se cargue y modifique los parámetros de .htaccess

El caso es que, ni en /pub ni en el resto de directorios de mi servidor, donde se encuentra la tienda. Lo he copiado en todas las carpetas que contienen el dichoso .htaccess, pero parece que no modifica los parámetros del servidor de apache, y el problema, creo, está ahí.

¿Alguna solución?

¿He de tratarlo directamente con el administrador de mi hosting?

Gracias de antemano y perdón por el tochazo.

Un saludo

Jordi
avatar
jordigsanz
ROOKIE ZENNER
ROOKIE ZENNER

Cantidad de envíos : 29
Inscripción : 17/04/2009
Edad : 38
Localización : En algún punto de la geografía Española ;)

Ver perfil de usuario http://www.replyphone.es

Volver arriba Ir abajo

Re: Problemas con EasyPopulate

Mensaje por MERVIR el Vie Abr 17, 2009 3:45 pm

mas sencillo todavia. en vez de crear un fichero crea dos ficheros y subes el 50% de la información el primero y el resto en el segundo
avatar
MERVIR
ZENNER
ZENNER

Cantidad de envíos : 695
Inscripción : 13/03/2009
Localización : Barcelona (España)

Ver perfil de usuario http://mervir.com/

Volver arriba Ir abajo

Re: Problemas con EasyPopulate

Mensaje por jordigsanz el Vie Abr 17, 2009 3:48 pm

Gracias por contestar Mervir, pero el problema lo tengo en "sentido" contrario. No puedo descargar el archivo de atributos porque EasyPopulate no lo genera. El error me lo da cuando trato de crearlo.

Saludos

Jordi
avatar
jordigsanz
ROOKIE ZENNER
ROOKIE ZENNER

Cantidad de envíos : 29
Inscripción : 17/04/2009
Edad : 38
Localización : En algún punto de la geografía Española ;)

Ver perfil de usuario http://www.replyphone.es

Volver arriba Ir abajo

Re: Problemas con EasyPopulate

Mensaje por MERVIR el Vie Abr 17, 2009 5:42 pm

has probado a exportar en por ftp y luego irlo a buscar? me refiero a descargarlo "internamente"
avatar
MERVIR
ZENNER
ZENNER

Cantidad de envíos : 695
Inscripción : 13/03/2009
Localización : Barcelona (España)

Ver perfil de usuario http://mervir.com/

Volver arriba Ir abajo

Re: Problemas con EasyPopulate

Mensaje por jordigsanz el Vie Abr 17, 2009 5:49 pm

Pues no lo he probado, sincéramente, porque no tengo ni idea de cómo se hace Very Happy Very Happy pero te estaría enormemente agradecido si me explicas brevemente cómo tengo que hacerlo.

De hecho, he pensado en borrar la mitad de artículos (dejar la bd en 1500 más o menos) que es cuando me funcionaba ok, crear de nuevo el archivo de atributos, bajarlo, volver a subir los artículos borrados, y modificar a mano el archivo de attribs con los nuevos productos (vamos, un currazo del copón, jejejejeje), pero fráncamente, ignoraba que existía la posibilidad que me comentas...
avatar
jordigsanz
ROOKIE ZENNER
ROOKIE ZENNER

Cantidad de envíos : 29
Inscripción : 17/04/2009
Edad : 38
Localización : En algún punto de la geografía Española ;)

Ver perfil de usuario http://www.replyphone.es

Volver arriba Ir abajo

Re: Problemas con EasyPopulate

Mensaje por MERVIR el Lun Abr 20, 2009 12:17 pm

desde la pantalla de descarga del easypopulate haz un click en

Create Complete tab-delimited .txt file in temp dir

y te lo descargará dentro de tu carpeta temp, abres por ftp y lo rescatas.
avatar
MERVIR
ZENNER
ZENNER

Cantidad de envíos : 695
Inscripción : 13/03/2009
Localización : Barcelona (España)

Ver perfil de usuario http://mervir.com/

Volver arriba Ir abajo

Re: Problemas con EasyPopulate

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.